Which browser I need to use?

It seems that I may have some problems with Safari. Any recomendations?

Hi, BLK!

Welcome to the community. To work with the Acure platform, we recommend to use Google Chrome Version 90+. Just in case you’ll have any additional questions, feel free to ask here or join our weekly Demo Meeting where we demonstrate the platform and can answer specific questions. We’d be happy to see you and assist in setting up the platform!